Apache HTTD 2.4: Invalid command ‘Order’, perhaps misspelled or defined by a module not included in the server configuration

Submitted by Jochus on Sat, 12/09/2015 - 20:16 | Posted in:


I recently upgraded one of my HTTPD severs from version 2.2 to 2.4. When I tried to start the Apache HTTPD daemon, I got the following exception:

Invalid command ‘Order’, perhaps misspelled or defined by a module not included in the server configuration failed

The problem was related to a change in the configuration specs of the "allow & deny rules". More info was found here. For a 2.4 configruation, you need to enable the following modules to be able to work with "authentication":

LoadModule access_compat_module modules/mod_access_compat.so
LoadModule authz_host_module modules/mod_authz_host.so

Add new comment

The content of this field is kept private and will not be shown publicly.

Full HTML

  • Lines and paragraphs break automatically.
  • You can caption images (data-caption="Text"), but also videos, blockquotes, and so on.
  • Web page addresses and email addresses turn into links automatically.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <bash>, <cpp>, <java>, <php>, <sql>, <xml>. The supported tag styles are: <foo>, [foo].